View Single Post
Old November 21st, 2014, 02:01 AM   #63
tattooed_pariah
Site Supporter
 
tattooed_pariah's Avatar
 
Join Date: May 2006
Location: El Cajon, California
Posts: 3,948
Member Photo Albums
Default Re: Effigy's history

Guess it's finally time I change my oil choice.. In California, I've always used 30 weight, it was fine, but it was also almost always the same temperature there..

It's been almost a month since I last started the bug, last time it ran, it sounded like the valves needed adjusting.. went out last night to fire it up (it's been in the 30's and 40 here this week..), took some carb cleaner down the barrels to get it to fire, and when it did, something popped and i saw a lot of smoke, so i shut it down and looked, and it looked like someone parked the exxon valdez in my driveway. Shined a light under and the rubber o-ring on my new oil filter was squeezed out..

My guess is that the oil was too thick, pressure built up too high, the o-ring was cold and then suddenly being heated, and the weakest point failed (the o-ring). That sound right to anyone else?

Thinking of switching to a 10w-30, maybe even 5w-30
__________________
-pariah

"I never trust a fighting man who doesn't smoke or drink or at least cause a little trouble." -Admiral William Frederick Halsey Jr.
===========
Feel free to stare and admire,
but kindly tell me if it's on fire!

1972 VolksRod "Effigy" Build Thread
1986 Honda Shadow VT1100 Work Thread
tattooed_pariah is offline   Reply With Quote